Author Topic: Having a bumpy ride on the forum? Please let us know!  (Read 23000 times)

gcsmusic

  • Administrator
  • Subsonic
  • *****
  • Posts: 14
  • Honor: 7
    • View Profile
Having a bumpy ride on the forum? Please let us know!
« on: February 04, 2016, 10:25:01 pm »
Hello everyone! I'm Guillaume Ceccarelli, and I'll be helping out with managing some of the technical aspects of the forum.

Over the next few days or maybe the next few weeks, we'll be making changes: adding features, setting up HTTPS, automating some of the spam fighting and doing a few other things to make this forum a better and safer experience for every one of you.

This doesn't come without risk for things to get a bit messy at times, so I would ask you to please let us know in case you see some things starts looking weird or not behaving as they should.

I'll see you around!

– Guillaume

Bizo

  • Sub Bass
  • *
  • Posts: 48
  • Honor: 5
  • Omelette du fromage
    • bizo_fr
    • bizo_fr
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #1 on: February 07, 2016, 04:48:16 am »
When I change the color theme, only the notifications icons of the sub-forums are changed ;)

I'm on Chrome btw

gcsmusic

  • Administrator
  • Subsonic
  • *****
  • Posts: 14
  • Honor: 7
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #2 on: February 07, 2016, 11:31:35 am »
Hey Bizo and thanks for reporting this!  :)

That's entirely my fault. There was a small problem with the theme we are using, for which my fix broke the color theme changing. I fixed the fix, and it should be fine now. Can you let me know if it works again for you?

Bizo

  • Sub Bass
  • *
  • Posts: 48
  • Honor: 5
  • Omelette du fromage
    • bizo_fr
    • bizo_fr
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #3 on: February 08, 2016, 01:53:52 pm »
Hey Bizo and thanks for reporting this!  :)

That's entirely my fault. There was a small problem with the theme we are using, for which my fix broke the color theme changing. I fixed the fix, and it should be fine now. Can you let me know if it works again for you?

No problem! And yes it's fixed, it's working again :)

gcsmusic

  • Administrator
  • Subsonic
  • *****
  • Posts: 14
  • Honor: 7
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #4 on: February 08, 2016, 02:22:55 pm »
Perfect!  :D

FarleyCZ

  • Mid
  • ***
  • Posts: 500
  • Honor: 93
    • farleycz
    • farleycz
    • View Profile
    • I tried to code a page, look!
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #5 on: February 08, 2016, 08:46:36 pm »


This notification got stuck eventhough I've read the message few days ago. It's behaving the same on several devices including a cell phone, so probably not a cookie problem. Small one, but just so you know. :)
"Earth is round right? Look at it from right angle and you'll be always on top of the world."
...but don't overdo it, because that's called being a d***k.

gcsmusic

  • Administrator
  • Subsonic
  • *****
  • Posts: 14
  • Honor: 7
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #6 on: February 08, 2016, 09:29:18 pm »
Hey Fariey, thanks for chiming in! :)

Can you send me a PM just to see if I can reproduce this one?

gcsmusic

  • Administrator
  • Subsonic
  • *****
  • Posts: 14
  • Honor: 7
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #7 on: February 08, 2016, 10:20:18 pm »
Hello again!

Thanks to your magnificent test PM, we're reproducing the issue. The fun part? I started looking around for a solution and... it's apparently a known bug in SMF (the forum software we're using), which has never been debugged completely by the developers.

The suggested workaround is to send yourself a PM to reset the counter, but even that doesn't seem to be working. So... looks like you're getting a permanent record of the number of PMs you've ever received on TPF. Nice feature. eh? Very innovative! :D

More seriously, we're looking into migrating from SMF to MyBB, which seems to be a better platform to build this forum upon in the long run. So hopefully, this message counter issue is one of the little problems that's just going to disappear once we make the move.

FarleyCZ

  • Mid
  • ***
  • Posts: 500
  • Honor: 93
    • farleycz
    • farleycz
    • View Profile
    • I tried to code a page, look!
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #8 on: February 08, 2016, 11:45:41 pm »
Hi Guillaume,

thanks for the help! :) ...you know what's interesting though? I recieved two messages before this one that succesfully reset the counter. Anyway, it's not a heavy issue by any mean. :)

Good luck with switching the forum engines. Database migration is always a pain in the a**. Fingers crossed. :)
"Earth is round right? Look at it from right angle and you'll be always on top of the world."
...but don't overdo it, because that's called being a d***k.

gcsmusic

  • Administrator
  • Subsonic
  • *****
  • Posts: 14
  • Honor: 7
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #9 on: February 09, 2016, 05:05:19 am »
Thanks for the good luck! :) It's sure going to be a lot of fun ;)

elixir

  • Sub Bass
  • *
  • Posts: 39
  • Honor: 7
    • ndetro
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #10 on: February 16, 2016, 03:00:55 pm »
I support the switch to mybb. Also, look into cloudflare. They offer great protection and free HTTPS.

gcsmusic

  • Administrator
  • Subsonic
  • *****
  • Posts: 14
  • Honor: 7
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #11 on: February 18, 2016, 11:56:09 am »
Thanks for your support and your recommendations!

I'm currently hosting this forum on the same infrastructure I use with my clients, which I manage myself for the most part. This gives us a few things like DDoS protection (without those annoying CloudFlare CAPTCHAs :) ) and service redundancies (3 different front-ends & back-ends + 3 different database servers, all synced and fully redundant)

HTTPS is also taken care of, not for free mind you, but free HTTPS from CloudFlare comes with a few inconveniences, including having to trust CloudFlare with inspecting every living thing exchanged between you and the forum (yikes), and taking away the ability to tune HTTPS settings to keep them set to what's best and what offers the best possible experience for everyone.

One thing that's missing that could come bundled with CloudFlare though is CDN-like caching. Shouldn't be too much of a problem though, since the forum is pretty lightweight and your browser should itself do a fine job at caching.

It's my job to maintain server infrastructure, so our bases are well covered. Doesn't mean that you can't come up with good suggestions though, so feel free to keep them coming if you have them! :)

Skele

  • Subsonic
  • Posts: 19
  • Honor: 1
  • Life doesn't last, make music that does
    • theskeletonboy
    • skelemusic
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #12 on: February 19, 2016, 01:22:58 am »
does anyone have any information regarding uploading an avatar? I've tried using a full res image, a 100x100 pixel image, even a 50x50. I keep getting a server error saying that it either timed out or the file was too large. Using mac 10.10 with safari. I will attempt to use firefox to see if that helps.
Life doesn't last, make music that does.


gcsmusic

  • Administrator
  • Subsonic
  • *****
  • Posts: 14
  • Honor: 7
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #13 on: February 19, 2016, 08:49:55 am »
Thanks for reporting the avatar problem! It's fixed! :)
I also repaired the search, which wasn't working quite well.

Please let me know if something's still off for you.

Bertie South

  • Low Mid
  • **
  • Posts: 250
  • Honor: 46
  • BERT
    • myboyfriendbob
    • View Profile
Re: Having a bumpy ride on the forum? Please let us know!
« Reply #14 on: February 19, 2016, 01:34:02 pm »
I was having that problem with avatars too, but since it was the same error message I was getting with attachments on posts (I think?), I assumed it was the same thing.


I can now upload an avatar, but still not add attachments. It now says 'the upload folder is full'.
Drum 'n' bass mixes: https://soundcloud.com/beenisss
Neither drum 'n' bass nor mixes: https://soundcloud.com/myboyfriendbob
Mixes, but not drum 'n' bass: https://mixcloud.com/Beenis